Honda Prelude Online banner

1 - 9 of 9 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1 (Edited)
Hey i just bought a pair of jdm fogs lights for 4th gen prelude and hooked it up and bought a relay from auto zone and did the paper clip switch and connected the orange, and yellow/red wires together and i know this worked for many people. The lights did not come on when i turned on my low beam any ideas what the problem can be? Any help will be helpful.
 

·
Unregistered User
Joined
·
4,287 Posts
Bulbs? Loose connection? Bad wirring? Get yourself a multimeter and check for voltage.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #4
I never changed the bulbs out so i think ill check and buy new ones and I don't have a multimeter to check my voltage. thanks for the answers
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
ok i have another problem now I tried to unscrew the screws to open the fog light to change out the bulbs but the screw are rusted on really bad and i stripped one screw, so i soaked it in wd-40 and going to wait a couple of hours is there anything else i can do??
 

·
Unregistered
Joined
·
4,054 Posts
I cut the heads off mine, took the cover / lens off, and unscrewed the remainder of the screw with a pair of pliers. Found replacement screws at Home Depot
 

·
Registered
Joined
·
23 Posts
Discussion Starter #7
do you mean to cut the screw heads right? because i do have extra screws to replace them just the old ones are rusted on good lol
 

·
Registered
Joined
·
23 Posts
Discussion Starter #9 (Edited)
ok thanks ill try that tomorrow and ill let you know if it worked and I'm going to order some ion yellow bulbs off ebay and try them thanks for your help

oh yeah forgot what should i use to cut the screw heads? not really familiar with this kind of work
 
1 - 9 of 9 Posts
Top