Honda Prelude Online banner

1 - 11 of 11 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter #1
basically this grinding noise started after i removed and re installed my power steering pump.. and i CANNOT figure out whats making this sound.. also when i turn the steering wheel car revs higher and shakes and grinds even more.. can anybody help..

thanks..

here is the video..

YouTube - 100 4299
 

·
Unregistered User
Joined
·
4,287 Posts
Is your alternator working right? I noticed your head light is turning on and off.
 

·
Registered
Joined
·
190 Posts
Discussion Starter #3
Is your alternator working right? I noticed your head light is turning on and off.

well it was working fine b4.. and the lights are turning on and off because its on remote start...

what happens.. is when i cold start it.. there is no noise.. but after i leave the car on and let it idle for 5 minutes.. it starts making that noise..
 

·
Registered
Joined
·
190 Posts
Discussion Starter #5
Maybe there's a problem with the re installation...
i made sure all the bolts are tightened...
dont really know how else to make sure its on there right..

well here is my question.. - why would turning the steering wheel feel really rough.. does that mean not enough fluid is going through the system or what..?
i filled up the reservoir..
 

·
Granny Shifter
Joined
·
247 Posts
Air bubbles is my guess. Drain and fill your power steering fluid. Check the Helms for the proper method, so you can be sure to get all of the bubbles out. Could also be a bad bearing where the pulley attaches to the pump. They are known to go bad once in a while.
 

·
Registered
Joined
·
190 Posts
Discussion Starter #7
Air bubbles is my guess. Drain and fill your power steering fluid. Check the Helms for the proper method, so you can be sure to get all of the bubbles out. Could also be a bad bearing where the pulley attaches to the pump. They are known to go bad once in a while.
yah im thinking its the air bubble thing.. well yah let me see if i can get the air out..

thanks Lude Acts
 

·
Registered
Joined
·
170 Posts
if you have air bubbles in your power steering resovoir you should be able to find a place where air is being sucked into the piping (that is where the bubbles will come from) check the seal on top of the power steering pump where the line connects. that was my problem.
 

·
Registered
Joined
·
190 Posts
Discussion Starter #11
.. i fixed... it.. *passes out* lol

u guys.. i donno what i did... but its gone.......

took me atleast 2 weeks to get this **** fixed ..

but yah i took the whole pump apart and put it back together.. atleast like 10 times.. but the last time.. i kinda filled the inside up with some fluids... and put it back together.. and that fixed it somehow. dont quote me on anything.. cuz i am not sure what exactly fixed it.. but all i know is that i KILLED THE ****ING ghost..

LMAO..

now.. on to.. replacing my ****ty SS tranny.. lol.

Thanks for all the replies guys.
 
1 - 11 of 11 Posts
Top