Honda Prelude Online banner
1 - 5 of 5 Posts

·
Nuke'em til they glow!
Joined
·
1,740 Posts
Discussion Starter · #1 ·
Ok,

As many of you know I've been having this rattle noise coming from the engine.

It was no different after the SS Auto to 5 Speed swap.

I've got no after market exhaust items installed.

There didn't seem to be a suspention issue.

Then I ran into a MIL code 61, a primary oxygen sensor "slow to respond" proplem.

GroverzVTEC indicated that I should check to see if my problem might be the engine KNOCKing.

So, I started checking things...

1) Fuel Filter
2) Spark Plugs
3) Cap & Rotor
4) Air Filter

Oddly, knock on wood, the problem seems to have stopped after I changed the fuel filter and ran a bottle of RedLine Injector Cleaner (fuel treatment) through the engine.

I also changed the cap and rotor, which had 60000 miles on them. They were very corroded. (The manual does not indicate a chance interval.)

The air filter is a K&N so I cleaned and re-oiled it. (Been about 20k)

Spark Plugs are on order. (NGK Iridiums)

I've also ordered an O2 sensor, but the bastards I got the NTK one from seem to think that the Primary and Secondary are the same. (...and refuse to believe me that they are not.) So I'm still looking for a reasonably priced Primary NTK or Denso O2 sensor...

Anyway, time will tell. The weather has been cold and my problem tends to show up more when it's warm.

If this was totally KNOCK or PING... it was a pretty loud friggen knock or ping problem.

I thought I'd share this, and it was so loud I was begining to look at things like wrist pins, etc.

Gerhard
 

·
Boost Withdrawl... :(
Joined
·
6,152 Posts
i still dont know what mine is...lol
 

·
Nuke'em til they glow!
Joined
·
1,740 Posts
Discussion Starter · #3 ·
At the moment I'm only suspecting this solved my problem.

It was really the RedLine injector cleaner that solved the problem so far as I can tell.

Gerhard
 

·
Boost Withdrawl... :(
Joined
·
6,152 Posts
do you think the injector cleaner could help cure a really bad lag problem??
 

·
Nuke'em til they glow!
Joined
·
1,740 Posts
Discussion Starter · #5 ·
MugenPoweredLude said:
do you think the injector cleaner could help cure a really bad lag problem??
Well, it must have done something... because my car is running a lot better.

I suspect that it defoulded the plugs and cleaned the injectors.

Also, my fuel pressure should be better as the fuel filter was quite clogged.

Gerhard
 
1 - 5 of 5 Posts
Top