Honda Prelude Online banner
1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
hey guys and girls ....

i have a question ...

i just got done installing
Neuspeed Race Springs and
Suspention Techniques Sway Bars ...

Ever time I go over a bump ...
It seems like there is a "THUMP"
noise coming from the rear ...
rear right is the one i notice ...

Could any one help me out ...
Thanks ...
 

·
Registered
Joined
·
149 Posts
Errrmmm.....is your rear sway bar hitting the exhaust? I have heard that this might be a problem....not sure about that though, but this is just a suggestion.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
i'll definitly check out the
sway bar and recheck all the bolt
tomorrow ...

"?" now when i tighten the top bolt
on the front shock ... the tire was
on the ground ... but when i did the
rear shock the car was still up in the
air ...

could that make a difference...
 

·
Registered
Joined
·
195 Posts
what year is your car?

cause on 97+ ludes I remember something about the bump stop needing to be modified.

at least thats what h&r and some other spring manufacturers say.
 

·
Registered
Joined
·
1,397 Posts
<font face="Verdana, Arial" size="2">Originally posted by Luder-xhpx:
what year is your car?

cause on 97+ ludes I remember something about the bump stop needing to be modified.

at least thats what h&r and some other spring manufacturers say.
</font>
yes, did you cut your bumpstop? especially with the drop of you race springs, the shock rod travel is severly reduced, and thus you might be bottoming out the shock. not good. i'd also check the torque on those rear bolts.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
... uh oh ...

"BUMP STOP"

not good ...

i don't think i even messed with the
bump stops ...

any one give me or tell me what at
bump stop look like and where ???
 
1 - 8 of 8 Posts
Top