Honda Prelude Online banner

1 - 14 of 14 Posts

·
Registered
Joined
·
662 Posts
Discussion Starter #1
I tried everything. liquid diamond, white
synthetic grease, mobile 1, dishwashing
detergent (ha ha).. lithium ion grease, etc.
and now that i got the squeek back.. I'd
like to know what your magic solution is.
Any fine greas'n ideas?

KC
 

·
Registered
Joined
·
9,437 Posts
good question! i want to know too... i don't just get a squeak, i got a got damn knock here and there after the tein installation (had to remove the sway bar to do it)! i tried silicone spray and green half-synthetic grease, the former dried out in no time, the latter hardened and didn't stay either...


------------------
<font face="Verdana, Arial" size="2">Originally posted by floundericiousFL:
you know...I've often thought...with MALKEN being an Admin...a castrated two-legged hampster with a learning disability could run this place better...</font>
 

·
Registered
Joined
·
662 Posts
Discussion Starter #5
<font face="Verdana, Arial" size="2">Originally posted by Jspec81:
vasoline


</font>

kuehahahahahaha...
It squeeks on me. So it'z gotta squeek on
ma Lude.


KC
 

·
Registered
Joined
·
584 Posts
Marine grease. Thats what my brother uses on the poly bushings on his Addco swaybar (96 Probe). I havent heard them squeak yet. This grease is waterproof, and really thick. It also feels really nasty on your hands, but it works. I think he paid $4.50 for a 1 lb container, you could give half to your friends and still have enough to last you a really long time. I dont remember the brand, but if you cant find it anywhere (we had a hard time), try a boat shop.

------------------
2001 Prelude Base
Electron Blue Pearl
No mods yet.
 

·
Registered
Joined
·
2,546 Posts
I forgot what i used, but.. mind dont squeek.. then agian I only have the front motor mount in. I might have just used liquid wrench.
 
7

·
Guest
Joined
·
0 Posts
How about buying polyurethane lubricant from Prothane or Energy Suspension? Ever thought about that?

------------------
Billy
North Texas Prelude Owners Group
www.ntpog.org
 

·
Registered
Joined
·
662 Posts
Discussion Starter #10
<font face="Verdana, Arial" size="2">Originally posted by 71dsp:
How about buying polyurethane lubricant from Prothane or Energy Suspension? Ever thought about that?

</font>
I didn't know Energy Suspension made lub
for poly bushings.. I have poly lub
from Gears and i'm guess it's being washed
off. Before this, I used to use synthetic
marine grease from Penzoil. That one used
to "dry off" unfortunately.
Now that I got the squeek back, i'm trying
to seek a permanent fix.. may be go back
to rubber... eeeeeek

KC
 

·
Premium Member
Joined
·
1,166 Posts
Moly-B is the best lubricant to use on this stuff. It is the same grease used on the back of brake pads, and on the caliper hardware to keep them from squealing. I can't spell the word correctly, but is something like Molybdenum. It is a graphite based lubricant and works wonders. I had the complete Poly bushing kit, and I had no squeaks at all.
 
7

·
Guest
Joined
·
0 Posts
<font face="Verdana, Arial" size="2">Originally posted by Merlin1xx1:
the stuff energy suspension sends with their bushings is crap. that stuff was dry as soon as it was put on. </font>
Then you must have received different lube than I did. I used the stuff that came with the bushings, and no squeeks yet. The stuff that came with my Neuspeed sway bars was the same syrup like lube. It's worked great as well.

------------------
Billy
North Texas Prelude Owners Group
www.ntpog.org
 
1 - 14 of 14 Posts
Top