Honda Prelude Online banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1 (Edited)
Hi! The fuel and temp gauges don't work on my 1992 si. I bought it like that. They would turn on normaly for like 2 seconds and shut off, it happened two times right after the car was turned on. Any help would be much appreciated! Thanks!
 

·
Premium Member
Joined
·
182 Posts
:( those are hard to fix. better off searching far and wide on the internet for a replacement. maybe custom gauge setup if youre into diy
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
:( those are hard to fix. better off searching far and wide on the internet for a replacement. maybe custom gauge setup if youre into diy
Man, that's a bummer. Thanks for the reply though! Could you give me some tips on something else? Right now I'm working on replacing its head gasket, but while I'm at it, it would be nice to upgrade the car a bit. Since I'm really new to preludes and the whole working on cars thing, I don't know what to replace. Any recommendations? It would be best if they were parts that wouldn't break the bank, cause my budget is pretty low!
 

·
Registered
Joined
·
11 Posts
That's a common problem, but few know how to resolve it. There are capacitors on the gauge board that are blowing out and need to be replaced.

Here's how to fix it, this thread helped me fix mine a few months ago and it's working perfectly: Fuel/Temp Gauge Fix (with Pics))

Let me know if it works for you.
 
1 - 5 of 5 Posts
Top