Honda Prelude Online banner
1 - 9 of 9 Posts

·
Registered
Joined
·
576 Posts
Discussion Starter · #1 · (Edited)
Ever since I bought my 01 with a JRSC on it it would make this horable noise when I turned right really hard and under acceleration. FYI The car was new when I got it and Honda installed the JRSC. Well after 4 months of honda searching for the problem, changing axles, CV joints, bla,bla, bla... they found it... It was the blower rubbing on the break booster... Anyone else have this problem? They put a piece of rubber their and the noise is gone...
 

·
Premium Member
Joined
·
522 Posts
whoa... honda installed your jrsc? that doesn't sound like something they would install. glad there helping you locate the problem though.
 

·
Registered
Joined
·
576 Posts
Discussion Starter · #5 ·
Actully the car was on the show room floor with the SC on it. I only bought it 4 months ago. It was the last Prelude still for sale (new) in NorthAmerica. They used it to show off what their dealership can do for mods and stuff... The reason I bought it is because everything is under warrenty.
 

·
Registered
Joined
·
576 Posts
Discussion Starter · #7 ·
Ya, after they installed the JRSC they also did an intake, DC header, N1 exhaust, WW RS kit, gauges, taillights, bla, bla,bla... the price on this car got insane so it sat their for almost two years. I got it for 8K CDN under their asking price. What sold me was the warrenty though...
 

·
Offtrack excursion expert
Joined
·
6,762 Posts
Paluce said:
Actully the car was on the show room floor with the SC on it. I only bought it 4 months ago. It was the last Prelude still for sale (new) in NorthAmerica. They used it to show off what their dealership can do for mods and stuff... The reason I bought it is because everything is under warrenty.
That is sooo not fair. :eek:
 
1 - 9 of 9 Posts
Top