Honda Prelude Online banner
1 - 13 of 13 Posts

·
Registered
Joined
·
695 Posts
Discussion Starter · #1 ·
the distributor its self or the cap and the rotor? Also would this cause my car to bog at RPM's greater then 3000K RPM? I'm starting to get tired of my jdm h22a, nothing but problems
 

·
Registered
Joined
·
835 Posts
Same thing happened to me, my distributor bearing was dead...

Start looking for a new distributor...
 

·
Registered
Joined
·
695 Posts
Discussion Starter · #5 ·
NO NO, not the answer i was looking for, anyone else :) i'm hoping its just the cap and rotor cap, i'm going to replace those tomorrow from honda, hopefully thats it. any way i could rebuild it? also could this be whats causing the bogging on my car?
 

·
Registered
Joined
·
695 Posts
Discussion Starter · #6 ·

·
Because Raptor!
Joined
·
2,753 Posts
when my distributor went out the car would bog. because there were metal filings inside the distributor and it wasn't getting a good enough connection.
 

·
Registered
Joined
·
695 Posts
Discussion Starter · #8 ·
yes, i took it apart today, and it was messy, tons of filings. Anyone read those Ebay distributors? they say the bearings and stuff are better then oem, so i'm thinking about going with one of those instead of a used oem one. What do you guys think ?

http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&category=6776&item=2415270951

yeah iknow thats an obdII and wont fit but it has all the benefits of buying off him, he also has obdI compatible with external coil.
 

·
Registered
Joined
·
695 Posts
Discussion Starter · #10 ·
OEM's too expensive....i cant afford 450+

These have a one year warrenty and the owner seemed pretty cool, they sound like they are good quality though, i'll let you guys know if i run into any problems.
 

·
Registered
Joined
·
1 Posts
i might be a little late helping you but maybe sum one could help me it sounds like what happened and is happening to me. my car was making weird noises idling weird and the check engine light only came on once. that it was a starter at first do to the sound making it seem like it was still trying to crank over but i looked at the distributor and took the cap off and behind the rotor is a plastic protective housing i dont think its suppose to be free floating and moving around. plade with it and everything stopped. it might be that housing rubbing on ur rotor look at that housing behind the rotor and see if its moving around and the rotors rubing on it.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top