Honda Prelude Online banner

1 - 14 of 14 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
Hi guys i been have an a little issue that would happen once a week but now has become a big annoyance, for about 2 weeks now my car has been feeling really "held back" or "restrained" every time i hit the throttle its almost like i have to hit Vtec to even feel a slight gain in power. I have changed oil recently, changed spark plugs, use premium gas. I have also started smelling a lot more exhaust fumes when driving with windows down and black spots on rear bumper right around exhaust area which from what i have read i might be running to rich? I don"t have CEL on. My dad told me to check if the O2 sensor might be done or my cat is clogged,but i have not had time to check that yet, but will soon. Also i notice that my RPM's jump very dramatically from time to time around 4000 RPM. I know what you guys are going to say...Its your clutch, but it does it when i rev the engine up and don't have it in gear...lol. Its almost like something electrical is touching the RPM wire and making it jump around. Will go from 3000RPM to 7000RPM on the cluster but the engine still feels like its revving normal. I'm not sure if you guys understand what i'm trying to say, Mechanically the car revs fine but the cluster says its not............lol if i put it in different perspective my 1995 honda Civic DX sedan can probably smoke my lude right now buy a lot feel my pain?.................lol its 1997 Base.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #3
THANKS FOR AN ANSWER!!!! air filter is OK, it was replaced about 2 weeks ago. I think its the cat havent checked, but could it really effect that much?
 

·
Warning: User Senile
Joined
·
2,585 Posts
Absolutely.
But it could also been an insane amount of things. Small things from a dirty fuel filter to a clogged injector to crap on your valves to a bad timing belt job.
It completely depends. Check out the many threads we have, look for 'h22 hesitation'.
 

·
Warning: User Senile
Joined
·
2,585 Posts
Also, post up your mileage. 97's have some kind of extended warrantee for emissions equipment.

About the tach, I'd suggest getting a helms to help troubleshoot circuits.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #6
Thanks Ludehawk, well today i took my cat out and well the inside pieces like the filter looking pieces are all melted and broken around i know it should not be like that, so i threw on a test pipe and the doesn't hesitate as much. But i still feel like i missing power i have 112,000 right now on it.
 

·
Registered
Joined
·
291 Posts
haha i have a 1995 civic dx sedan...along with my lude..wanna race?? haha...jk its got no motor..getting a swap right now...
 

·
Registered
Joined
·
291 Posts
HEY HOPE SOMEONE CAN HELP ME OUT, i have a bad problem with my lude, while im driving sometimes it feels like my car is going to cut off, im pushing the gas and feels like it has no pressure, and when im taking off at a light or so, it like shakes like its about to stall, but i turn it off and its ok for a min and after same thing, it feels like it gonna stall and i have to give alot of gas, and when its parked and this problem is active i give a bit of gas and it doesnt rev properly..any idea of what problem might be, heard it might be the fuel filter, someone please help me out...
dont be thread jacking man..create your own post..
 

·
Registered
Joined
·
291 Posts
when someone else uses someone elses thread as their own..instead of starting their own thread...
 

·
the satisfier
Joined
·
808 Posts
Have you checked the ignition timing? Also make sure your cap, rotor, and wires are in good shape.
 
1 - 14 of 14 Posts
Top