Honda Prelude Online banner
1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I am having a challenge with my A/C in my 91 Si 4WS. It blows cool only intermittently. I have noticed that the cooling fan on the driver's side is not working, could that be related to my A/C challenge? I also notice that in the sight glass on my receiver/dryer, the refrigerant appears milky looking. Does anyone have any experience with A/C systems that could give me a clue as to what my problem might be?

Also, should it be that I need some new parts, can anyone speak to the viability of the R134 conversion kits offered at most auto parts stores these days?
 

·
Registered
Joined
·
1 Posts
I have a 91 2.0si and am having the exact same problem. However, my driver's side fan appears to be working. Don't even think about those retrofit kits. I wasted my time and money on one with zero benefit. I don't have the cash to get it checked out but here in the South, A/C is a must. If you get it resolved please post the results. Thx
 

·
Registered
Joined
·
22 Posts
Did you check if your freon is full? If not try to charge it up the kit only costs like 50 bucks to refill your freon.
 

·
Registered
Joined
·
21 Posts
I'm no refrigerent specialist but.. I'm pretty shure bubbles in your sight mean you have air in your system. As far as milkyness I think your sight should be clear with a good clean charge. On a side note does anybody have a good source for quality aftermarket A/C hoses? Do they exist? I need one! and I don't want to pay for a dealer one. thanx! p.s. you may need your system vacuum pumped empty for good recharge if there is nothing else wrong.
 
1 - 5 of 5 Posts
Top