Honda Prelude Online banner

1 - 12 of 12 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hey all, I have a 99 base model. It all started with my turbo kit, 6k later i was makn 300 to the wheels. Then one day i discovered that mt cv joint boots were gone. The joints were trashed. The car literally shook violently for a couple of days before i took it to a shop. He replaced the axle and both joints. Then a week later i notice that my garage has gear oil on the floor. In my head i wonder if he nic'ed the seal on the trans puttn the axle into it. Well dumb me ran the car not thinking of it. Then one day along a drive i felt a slight shake upon acceleration. Its the cv joint again i thought. Took it to the shop, he replaced it, no luck. Slowly got worse the more i drove it. Finally i took it to another shop. he said it was my clutch. He took everything all apart changed the clutch which was bad, and fly wheel. Swapped out the busted motor mount and buttoned it all up. I get it back and it still does it. The guy says its my tires LOL!!! If it was my F'n tires why would it only do it upon accelerating? It is this weird shake, if i do 30 and acc its a slow *** *** ***. If i go 60 its much faster and stronger. Did i fry my trans when i ran it with low or no oil??? Im so frustrated...
 

·
Registered
Joined
·
210 Posts
Did you resurface the flywheel?

What clutch are you using? OEM wouldn't be able to handle 300 hp
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
I was boosting 10lbs. And my new clutch is equivalent to stock... I know. But when i got it back from the clutch swap, it did the same thing... so that immediatly mekes me think its not the clutch slipping again. O and one more thing, if it was the trans wouldnt it be making noise?
 

·
Registered
Joined
·
599 Posts
it depends, were driving aggresively? like launching/power shifting, etc. If its a new clutch then when you bought it you should have upgraded.
 

·
Merovingeon
Joined
·
561 Posts
wow..$6,000 and made 300 to the wheels.....
 

·
I am now a 5spd lude!
Joined
·
474 Posts
^^^Im assuming thats a bad "wow"?
 

·
Merovingeon
Joined
·
561 Posts
Well...I guess it depends on your outlook...$6,000 in my 6.2L V8 powered rx7 will get me about 900 to the ground..maybe more....
 

·
I am now a 5spd lude!
Joined
·
474 Posts
show off.....$6k cant even get that much HP out of my GTO
 

·
Merovingeon
Joined
·
561 Posts
not to get off topic, but the LS2's in the goats can be pretty mean. Most guys will slap a set of L92 heads on them and go to town. Those heads will flow over 300cfm @.600 lift with no porting!! Im running the L92 motor in my 7. I've got valvetrain upgrades, an LG motorsports cam, LS3 intake manifold and a good exhaust and headers. Stock its rated at 410Hp and like 430ft lbs tq. I bought the motor for $2200 and then put about another $1800 into it with various parts, the cam, the labor, etc. Im expecting about 500-550 crank HP and thats no power adders, all NA. Rather than upgrade the cam and all that stuff, I could have just as easily turbo'ed that motor. My buddy who has a turbo 5.7L Ls1 in his rx7, just put down 685 to the ground on pump gas with meth injection as a safeguard. Thats why I cringed when I saw $6000 for 300hp to the wheels. the best part is, with T56 6 speed, I should average about 27-29 mpg on the highway, which coincidentally, is the same MPG my prelude makes.
 
1 - 12 of 12 Posts
Top