car wont rev past 3k and tdc code on - Honda Prelude Forum
Honda Prelude Forum Honda Prelude Forum Header Right
» Auto Insurance
» Featured Product
Wheel & Tire Center

» Log in
User Name:

Password:

Not a member yet?
Register Now!
Go Back   Honda Prelude Forum > Honda Prelude Discussion > Fifth Gen Prelude Discussion
Register Home Forum Active Topics Photo Gallery Mark Forums Read Auto EscrowInsurance Advertise

PreludeOnline.com is the premier Honda Prelude Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread Display Modes
Old 01-21-2017, 12:29 PM   #1 (permalink)
Registered User
 
Join Date: May 2013
Posts: 9
iTrader: (0)
Feedback Score: 0 reviews
car wont rev past 3k and tdc code on

98 prelude sh.

I made a bad decision to race my car earlier tonight. I was running it pretty hard, with some mishifts and accidentally redlining like a noob.

anyway after all that, My CEL came on and I noticed that my engine would not rev past 3k ( regardless of gear, even neutral ) drove it home and checked the code (paper clip method, 8 fast blinks, code 8 , tdc sensor ). disconnected battery and connected it again ( reset the ecu ). Car takes forever to start and is cranking very oddly.

Did my timing belt slip a tooth? or is it possible that my tdc sensor got knocked out loose? or did it just go bad on me?

what should i begin to check for first?

car sounds fine and drives fine except wont rev past 3k and it cranks very weird, making it hard for it to start. Any advice before I start trowing parts at it will be very helpful. Thank you
pike0825 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-21-2017, 02:35 PM   #2 (permalink)
Registered User
 
Join Date: May 2013
Posts: 9
iTrader: (0)
Feedback Score: 0 reviews
got the car checked out today and they told me the timing if off by a couple notches and that I will have to redo the belt to set it correctly. Im wondering if any internal damage was done to the engine while driving it back home like this. The ran sounded fine and ran fine. just wont revd past 3k. Do engines bust when you drive it with bad timing?
pike0825 is offline   Reply With Quote
Old 02-17-2017, 02:14 AM   #3 (permalink)
Registered User
 
Kakashi66218's Avatar
 
Join Date: Jul 2016
Location: Kansas
Posts: 6
iTrader: (0)
Feedback Score: 0 reviews
Quote:
Originally Posted by pike0825 View Post
got the car checked out today and they told me the timing if off by a couple notches and that I will have to redo the belt to set it correctly. Im wondering if any internal damage was done to the engine while driving it back home like this. The ran sounded fine and ran fine. just wont revd past 3k. Do engines bust when you drive it with bad timing?
From my own experience, I ended up with the valves of the cylinder head bent and leaky. Compression issues may be the cause of your startup problems.


Isn't the tDC sensor at the crankshaft? There may be more going with that engine concidering what is stated.

Someone more knowledgeable than me may be along.
Kakashi66218 is offline   Reply With Quote
 
Old 02-17-2017, 11:31 PM   #4 (permalink)
Registered User
 
Join Date: May 2013
Posts: 9
iTrader: (0)
Feedback Score: 0 reviews
I already got my car checked out and everything. the exhaust valves on cylinder 2 and 4 were bent. They changed the timing belt and tensioner. The car still runs surprisingly well but i can tell the engine is not all there like it used to. Im not trying to drop another 1,500 on a valve job so im just riding it like this for now.
pike0825 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Honda Prelude Forum > Honda Prelude Discussion > Fifth Gen Prelude Discussion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
bouncing idle and wont rev past 4k taw1986 Naturally Aspirated 3 08-18-2012 10:02 AM
Got CEL code 8 TDC sensor. need help 1996PreludeVTEC Fourth Gen Prelude Discussion 10 12-01-2010 11:39 PM
98 prelude bogs no rev past 6000 dirttracker7x Fifth Gen Prelude Discussion 1 06-06-2010 11:13 AM
jdm h22 wont rev past 6k Rudaluda General Prelude Discussion 14 09-28-2005 05:36 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 11:47 PM.



Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.